Skip to content

Magento 1.x Error on PHP 7.2

After upgrading on of my clients environment from PHP7 to PHP 7.2, the client reported not being able to open any customers in the admin dashboard. The logs showed the following error:

To fix this I add to overwrite a few Magento core files and change the function  getAllOptions .

In order to still be able to update your Magento shop, copy the following files from /app/code/core/  to   /app/code/local .

Now copy the following files to you local folder:

In those files you need to replace the following line

with

 

Published inUncategorized

One Comment

  1. Nova

    Hi Kevin…I just wanted to say thanks this actually helped me, good job!

Leave a Reply

Your email address will not be published.